Veeam MP for System Center Resource Kit

 Top Next

The Veeam MP Resource Kit includes the following items:

Deployment guidance and tools

· Veeam MP for VMware Sizing Calculator
· Veeam MP for Hyper-V Sizing Calculator

Additional MPs for advanced analysis and custom configurations

· Veeam VMware High-Granularity MP
· Veeam All Objects in Belgium Monitoring Group MP
· Veeam Disable All VM Workflows MP
· Veeam Disable All Alerts MP

Scripts and tools

· Script to create local accounts on vSphere hosts for use in vCenter Connection Failover
· Script to remove Veeam Run As accounts from Secure Reference MP

Data Analysis tools

· Veeam VMware PowerPivot Example

Reference documentation

· Veeam MP for VMware Reference
· Veeam MP for Hyper-V Reference
· MP for Veeam Backup & Replication Reference

To get the most up-to-date Resource Kit version, visit the Veeam MP Online Help Center.


Veeam MP for VMware Sizing Calculator

 Top Previous Next

The Veeam MP for VMware Sizing Calculator calculator is a spreadsheet which allows you to accurately estimate the data volume which the Veeam MP will require in your Ops Mgr operational database and data warehouse database. By entering the number of hosts, VMs and other components you can calculate the database requirements of the Veeam MP for VMware.

For full instructions open the spreadsheet and follow the directions in the first worksheet.


Veeam MP for Hyper-V Sizing Calculator

The Veeam MP for Hyper-V Sizing Calculator calculator is a spreadsheet which allows you to accurately estimate the data volume which the Veeam MP will require in your Ops Mgr operational database and data warehouse database. By entering the number of hosts, VMs and other components you can calculate the database requirements of the Veeam MP for Hyper-V.

For full instructions open the spreadsheet and follow the directions in the first worksheet.


Veeam VMware High-Granularity Management Pack

Veeam MP 7.0 R2 for System Center includes the Veeam VMware High-Granularity MP — management pack with additional performance collection rules for advanced and granular performance monitoring.

This MP can be considered optional, as the metrics collected are not used in any out-of-box Veeam MP for VMware dashboard, alert, or report. This MP should be deployed only when specific advanced performance analysis is required. It should be enabled on a per-Host or per-VM basis.

note Note

This additional performance data is very granular, especially as it is mostly instance-based data, and this MP should be used with caution to avoid heavy load and space usage in the Ops Mgr databases.

The Veeam VMware High-Granularity MP includes the following additional metrics:

Object | Counter | Instance
VMDatastore | deviceReadLatency (for each Host:Disk to this datastore) | Host name:disk name
VMDatastore | deviceWriteLatency (for each Host:Disk to this datastore) | Host name:disk name
VMDatastore | freeMB | partition name
VMDatastore | IOPS(for each Host:Disk to this datastore) | Host name:disk name
VMDatastore | SDRS Normalized Read Latency | _Total
VMDatastore | SDRS Normalized Write Latency | _Total
VMDatastore | SDRS Outstanding Read Requests | _Total
VMDatastore | SDRS Outstanding Write Requests | _Total
VMDatastore | SDRS Read IOPS | _Total
VMDatastore | SDRS Write IOPS | _Total
VMDatastore | SIOC Max Queue Depth | _Total
VMDatastore | VMObservedLatency | _Total
VMGuest-cpu | cpuIdlePct | _Total
VMGuest-cpu | cpuWaitPct | _Total
VMGuest-disk | freePct | Disk partition name
VMGuest-disk | outstandingIOs (sum readOIO and writeOIO) | Datastore name:Virtual disk name
VMGuest-disk | usageRateKB/s (sum read + write rate) | Datastore name:Virtual disk name
VMGuest-memory | memorySharedKB | _Total
VMGuest-net | receiveRateKB/s | vNIC name
VMGuest-net | transmitRateKB/s | vNIC name
VMHost-cpu | cpuIdlePct | _Total
VMHost-disk | commandsFailed | Datastore name:Disk name
VMHost-disk | kernelLatency | Datastore name:Disk name
VMHost-disk | kernelReadLatency | Datastore name:Disk name
VMHost-disk | kernelWriteLatency | Datastore name:Disk name
VMHost-disk | maxQueueDepth | Datastore name:Disk name
VMHost-disk | readRateKB/s | Datastore name:Disk name
VMHost-disk | usageRateKB/s | Datastore name:Disk name
VMHost-disk | writeRateKB/s | Datastore name:Disk name
VMHost-hba | readLatency | vmhba name (e.g. vmhba33)
VMHost-hba | readRateKB/s | vmhba name (e.g. vmhba33)
VMHost-hba | writeLatency | vmhba name (e.g. vmhba33)
VMHost-hba | writeRateKB/s | vmhba name (e.g. vmhba33)
VMHost-memory | memoryActiveMB | _Total
VMHost-memory | memoryAvailPct | _Total
VMHost-memory | memorySwappedMB | _Total
VMHost-memory | memorySharedMB | _Total
VMHost-net | droppedRx | Vmnic name
VMHost-net | droppedTx | Vmnic name
VMHost-net | receiveRateKB/s | Vmnic name
VMHost-net | transmitRateKB/s | Vmnic name
VMHost-sensor | Amps | Sensor name
VMHost-sensor | Degrees C | Sensor name
VMHost-sensor | Percentage | Sensor name
VMHost-sensor | Percentage | Sensor name
VMHost-sensor | Volts | Sensor name
VMHost-sensor | Watts | Sensor name
VMPool | vmShutdown | _Total
VMPool | vmSuspended | _Total
VmvApp | vmShutdown | _Total
VmvApp | vmSuspended | _Total

All rules included in the Veeam VMware High-Granularity MP are disabled by default. To enable performance data collection, manually add vSphere clusters, datastores, hosts and/or VMs to the Veeam VMware objects for high-granularity performance collection group:

1. Open the Ops Mgr console using the account with administrative rights.
2. Go to the Authoring section and select Groups.
3. In the list of groups, double-click the Veeam VMware objects for high-granularity performance collection group.
4. In the Veeam VMware objects for high-granularity performance collection Properties window, open the Explicit Members tab and click Add/Remove Objects.
5. In the Object Selection window, search for the necessary vSphere clusters, datastores, hosts and/or VMs, add them to the list of group members and click OK.
6. Click OK to save changes.

For more information on performance collection rules included in the Veeam VMware High-Granularity MP, see Veeam MP for VMware Online Reference.


Veeam All Objects in Belgium Monitoring Group Management Pack

You can logically group specific Collectors into monitoring groups in the Veeam UI. The Veeam All Objects in Belgium Monitoring Group MP dynamically includes objects discovered on these Collectors into groups in the Ops Mgr console. You can later use Ops Mgr User Roles to give users different permissions to see objects in that group.

note Note

If you need to create another group, except Belgium, you will also need to modify the Veeam.All.Objects.in.Belgium.Monitoring.Group.xml by replacing all “Belgium” text by the name of the corresponding monitoring group in the Veeam UI.

In the xml code, only alphanumeric characers in monitoring group names are allowed, no space characters are supported.
1. Create a monitoring group (in this example — the Belgium monitoring group) in the Veeam UI.
2. Move the required Collectors to the monitoring group.
3. Import the Veeam All Objects in Belgium Monitoring Group MP.

The Veeam.All.Objects.in.Belgium.Monitoring.Group.xml will create two groups in the Ops Mgr console:

· Veeam Objects in Belgium Monitoring Group includes all objects from the Belgium monitoring group in the Veeam UI.
· Veeam vCenter objects in Belgium Monitoring Group includes a vCenter Server from the Belgium monitoring group in the Veeam UI.

After you import the MP, the Belgium Monitoring Group topology view will become available in the root Monitoring folder. The topology will be populated with objects from the Belgium monitoring group.


Veeam Disable All VM Workflows Management Pack

The Veeam.Disable.All.VM.Workflows.xml creates a ‘Veeam Unmonitored VMs’ group for VMs whose monitoring should be disabled. Then the management pack disables all virtual machine workflows including performance and event collection rules.


Veeam Disable All Alerts Management Pack

The Veeam.Disable.All.Alerts.xml disables all alerts from VMs in your environment. However, health state will still be monitored (VMs will change state, but no alerts will be generated), and events and performance metrics for these VMs will still be collected.


Add ESXi User PS Script

If you are planning to use the vCenter Connection Failover feature, you will need to configure the Veeam VMware Direct ESX(i) Connection Account. While configuring the account, you will be asked to specify user name and password that will be used for direct-to-host connections. The specified credentials must be the same for all vCenter managed ESX(i) hosts in your environment (even hosts in different vCenter Servers).

The Add-ESXiUser.ps1 script allows you to automatically create identical local accounts on vSphere hosts for use in vCenter Connection Failover.

For more details about vCenter Connection Failover, refer to the Veeam MP for VMware Operations Guide, vCenter Connection Failover section.


Remove Veeam Secure Reference PS Script

The Remove_Veeam_SecureReference.ps1 script allows you to automatically clean Veeam MP dependencies from the Microsoft.SystemCenter.SecureReferenceOverride MP. For details on cleaning dependencies, see www.veeam.com/kb1898.

Before you use the script, make sure that you have previously removed all configured accounts from Run As profiles and created a backup of the Microsoft.SystemCenter.SecureReferenceOverride MP.


Visualizing Veeam MP Data Using Microsoft PowerPivot

Microsoft SQL Server PowerPivot for Microsoft Excel (PowerPivot for Excel) is a free SQL Server 2008 R2 add-in to Excel 2010 and 2013. PowerPivot for Excel is used for adding, analyzing and visualizing large amounts of data in Excel workbooks. To learn more about PowerPivot for Excel, visit Microsoft Technical Center.

The Veeam VMware PowerPivot Example workbook includes worksheets with sample statements that you can use when creating SQL queries for importing data from your Ops Mgr DW.

The workbook also contains customizable sample tables and charts that display statistics on various performance metrics to help you analyze health and performance of virtual infrastructure objects and evaluate the efficiency of resource utilization.

Importing data from Ops Mgr Data Warehouse

Veeam VMware PowerPivot Example


Importing data from Ops Mgr Data Warehouse

PowerPivot for Excel allows you to import, filter, sort and build relationships between data from different data sources. Particularly, you can create a PowerPivot connection to the Ops Mgr Data Warehouse and extract Veeam objects for performance data analysis and reporting purposes:

note Note

The procedure below applies to Microsoft Excel 2013. Similar actions can be performed in Microsoft Excel 2010.
1. Make sure that all hardware and software prerequisites are met for the computer used to create PowerPivot workbooks.
2. Launch Microsoft Excel, open the PowerPivot tab and click Manage.
3. In the PowerPivot for Excel window, switch to the Home tab and click From Database > From SQL Server to open the Table Import Wizard.
4. At the Connect to a Microsoft SQL Server Database step, select the server which hosts Ops Mgr Data Warehouse from the Server name drop-down list, specify credentials used to connect to the server and choose a database to collect data from.

Connect to a Microsoft SQL Server Database

5. At the Connect to a Microsoft SQL Server Database step, select the Write a query that will specify the data to import checkbox.
6. At the Specify a SQL Query step, type the name of the PowerPivot table in the Friendly Query Name field. Then type a SQL query in the SQL Statement field.

Some examples of SQL statements are described in section Veeam VMware PowerPivot Example.

7. Click Finish to save the query.
8. Once you have created all the queries you need, establish relationships between the tables:
a. In the PowerPivot for Excel window, switch to the Home tab and click Diagram View.
b. Right-click the necessary column header and click Create Relationship.
c. In the Create Relationship window, select the table and the row in this table with which you want to create a relationship.

Create a relationship

Alternatively, simply drag and drop the necessary columns to the tables you want to create relationships with.

Create a relationship manually


Usage Example

Now, you can create your own sample pivot table for vSphere hosts in the environment to show all average performance metric values that have been recorded to the Ops Mgr DW during the previous 7 days:

1. In the PowerPivot for Excel window, switch to the Home tab and select PivotTable > PivotTable.
2. In the Insert Pivot window, select New Worksheet. This will open a new worksheet in Excel.

Insert a pivot

3. In PivotTable Fields, expand the Entities drop-down list, right-click ManagedEntityTypeDefaultName and select Add to Report Filter. This will add a new filter for monitored objects in the worksheet.

Add a new filter

4. Expand the drop-down list in the cell with the All value and select VMware vSphere Host. This will narrow the filter results to the objects of the VMware vSphere Host class.

Select VMware vSphere Host class

5. In PivotTable Fields, expand the Perf drop-down list, right-click CounterName and select Add to Column Labels. This will add new columns with performance metric names in the worksheet.

Similarly, righ-click AverageValue, and select Add to Values. This will display metric values for each column in the worksheet.

Add new columns

6. In the VALUES field, expand the Sum of AverageValue drop-down list and select Value Field Settings.

In the Value Field Settings window, select Average from the Summarize value field by list.

Specify field settings

7. In PivotTable Fields, expand the Entities drop-down list, right-click DisplayName and select Add to Row Labels. This will display a list of hosts in the worksheet.

Add new rows

You can use conditional formatting and highlight hosts with the highest CPU usage level:

1. Select values in the cpuUsageMHz column.
2. On the Home tab, click Conditional Formatting > Color Scales > Red – Yellow- Green Color Scale.

Use conditional formatting

You can also add a timeline to narrow the time frame for data analysis:

1. Open the Pivot Tools Analyze tab and click Insert Timeline.
2. In the Insert Timeline window, select Perf.DateTime and click OK.

Insert a timeline

In the DateTime window, adjust timeline to show DAYS. Then stretch the timeline to include the exact dates for which you want the data to be analyzed.

Adjust date and time interval


Veeam VMware PowerPivot Example

This section provides instructions on how to work with the Veeam VMware PowerPivot Example.

Step 1. Connect to the Ops Mgr Data Warehouse

Step 2. Modify Sample SQL Statements

Step 3. Change Spreadsheet Options


Step 1. Connect to the Ops Mgr Data Warehouse

Before you start working with spreadsheets in the Veeam VMware PowerPivot Example workbook, connect to your Ops Mgr DW to retrieve data from it:

1. Launch Microsoft Excel, open the PowerPivot tab and click Manage.
2. In the PowerPivot For Excel window, switch to the Home tab and click Existing Connections.
3. In the Existing Connections window, select the SCOM_DW data source and click Edit.

Choose a data source

4. In the Edit Connection window, expand the Server name drop-down list and choose your server which hosts Data Warehouse.

Choose a DW server

Click Test Connection, wait for the connection to be tested, click OK and then click Save.

Test the connection

5. On the Home tab, click Refresh > Refresh All, wait for the new data to be retrieved and click Close.

6. Close the PowerPivot For Excel window.


Step 2. Modify Sample SQL Statements

Each Veeam VMware PowerPivot Example spreadsheet displays data returned by sample SQL queries. You can edit the query statements to meet your specific needs:

note Note

All sample queries below return data recorded to the Ops Mgr Data Warehouse during the previous 7 days.
1. Launch Microsoft Excel, open the PowerPivot tab and click Manage.
2. In the PowerPivot for Excel – Veeam VMware PowerPivot Example window, switch to a worksheet, open the Design tab and click Table Properties:
· The query on the Perf worksheet returns changes in performance metric values and shows metric sample count, minimum, maximum and average values.

The Perf sample query

SELECT PERF.ManagedEntityRowId

,PR.RuleRowId

,PERF.DateTime

,PERF.AverageValue

,PERF.MinValue

,PERF.MaxValue

,PERF.SampleCount

,PR.ObjectName

,PR.CounterName

,PRI.InstanceName

FROM Perf.vPerfHourly PERF

INNER JOIN vPerformanceRuleInstance PRI ON PRI.PerformanceRuleInstanceRowId = PERF.PerformanceRuleInstanceRowId

INNER JOIN vPerformanceRule PR ON PR.RuleRowId = PRI.RuleRowId

WHERE PERF.DateTime > (GETUTCDATE() - 7)
· The query on the Entities worksheet returns a list of monitored objects and shows classes to which these objects belong.

The Entities sample query

select distinct

ME.ManagedEntityRowId

,ME.Name

,ME.DisplayName

,ME.Path

,MET.ManagedEntityTypeDefaultName

from Perf.vPerfHourly PERF

inner join vManagedEntity ME on ME.ManagedEntityRowId = PERF.ManagedEntityRowId

inner join vManagedEntityManagementGroup MEMG on MEMG.ManagedEntityRowId = ME.ManagedEntityRowId

inner join vManagedEntityType MET on MET.ManagedEntityTypeRowId = ME.ManagedEntityTypeRowId

where PERF.DateTime > (GETUTCDATE() - 7)

order by MET.ManagedEntityTypeDefaultName
· The query on the MPs and Rules worksheet returns alist of performance collection rules and management packs in which these rules are included.

The MPs and Rules sample query

SELECT distinct RU.RuleRowId

,MP.ManagementPackDefaultName

,MP.ManagementPackSystemName

,RU.RuleDefaultName

FROM vManagementPack MP

inner join vRule RU on RU.ManagementPackRowId = MP.ManagementPackRowId

inner join vPerformanceRule PR on PR.RuleRowId = RU.RuleRowId

where PR.LastReceivedDateTime > (GETUTCDATE() - 7)
· The query on the Properties worksheet returns a list of the latest object property values, such as the number of vCPUs or the amount of allocated memory.

The Properties sample query

SELECT

p.ManagedEntityRowId,

d.DisplayName,

vmetp.PropertyGuid,

vmetp.PropertySystemName,

PropertyValue = p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp.PropertyGuid")]]/text())[1]','nvarchar(256)'),

p.FromDateTime,

p.ToDateTime

FROM

[OperationsManagerDW].[dbo].[vManagedEntityProperty] as p

INNER JOIN [OperationsManagerDW].[dbo].[vManagedEntity] d ON p.ManagedEntityRowId = d.ManagedEntityRowId

Inner join [OperationsManagerDW].[dbo].[vManagedEntityTypeProperty] vmetp on vmetp.ManagedEntityTypeRowId=d.ManagedEntityTypeRowId

Where p.ToDateTime IS NULL
· The query on the DatastoreswithDiskSize worksheet returns a list of monitored datastores and shows their capacity.

The DatastoreswithDiskSize sample query

select distinct

ME.ManagedEntityRowId

,ME.Name

,ME.DisplayName

,ME.Path

,MET.ManagedEntityTypeDefaultName

,convert(float,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp.PropertyGuid")]]/text())[1]','nvarchar(256)')) as DiskSize

from vManagedEntity ME

inner join vManagedEntityManagementGroup MEMG on MEMG.ManagedEntityRowId = ME.ManagedEntityRowId

inner join vManagedEntityType MET on MET.ManagedEntityTypeRowId = ME.ManagedEntityTypeRowId

Inner join vManagedEntityTypeProperty vmetp on vmetp.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId

inner join vManagedEntityProperty p on p.ManagedEntityRowId=ME.ManagedEntityRowId and vmetp.PropertySystemname like 'diskSize' and p.ToDateTime is Null

order by MET.ManagedEntityTypeDefaultName
· The advanced query returns а list of monitored Hyper-V VMs and shows their most important properties.

select distinct

ME.ManagedEntityRowId

,ME.Name

,ME.DisplayName

,ME.Path

,MET.ManagedEntityTypeDefaultName

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp.PropertyGuid")]]/text())[1]','nvarchar(256)') as HostName

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp2.PropertyGuid")]]/text())[1]','nvarchar(256)') as cpucount

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp3.PropertyGuid")]]/text())[1]','nvarchar(256)') as guestHostName

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp4.PropertyGuid")]]/text())[1]','nvarchar(256)') as clustername

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp5.PropertyGuid")]]/text())[1]','nvarchar(256)') as MaxMem

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp6.PropertyGuid")]]/text())[1]','nvarchar(256)') as DiskAllocationGB

,p.PropertyXml.value('(/Root/Property[@Guid[. = sql:column("vmetp7.PropertyGuid")]]/text())[1]','nvarchar(256)') as UsesStorage

from vManagedEntity ME

inner join vManagedEntityManagementGroup MEMG on MEMG.ManagedEntityRowId = ME.ManagedEntityRowId

inner join vManagedEntityType MET on MET.ManagedEntityTypeRowId = ME.ManagedEntityTypeRowId

inner join vManagedEntityProperty p on p.ManagedEntityRowId=ME.ManagedEntityRowId and p.ToDateTime is Null

Inner join vManagedEntityTypeProperty vmetp on vmetp.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp.PropertySystemname like 'hostname'

Inner join vManagedEntityTypeProperty vmetp2 on vmetp2.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp2.PropertySystemname like 'cpucount'

Inner join vManagedEntityTypeProperty vmetp3 on vmetp3.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp3.PropertySystemname like 'guestHostName'

Inner join vManagedEntityTypeProperty vmetp4 on vmetp4.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp4.PropertySystemname like 'clustername'

Inner join vManagedEntityTypeProperty vmetp5 on vmetp5.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp5.PropertySystemname like 'maxmem'

Inner join vManagedEntityTypeProperty vmetp6 on vmetp6.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp6.PropertySystemname like 'DiskAllocationGB'

Inner join vManagedEntityTypeProperty vmetp7 on vmetp7.ManagedEntityTypeRowId=ME.ManagedEntityTypeRowId and vmetp7.PropertySystemname like 'UsesStorage'

order by MET.ManagedEntityTypeDefaultName
3. Edit the query statement in the SQL statement field.
4. Click Save.


Step 3. Change Spreadsheet Options

Sample spreadsheets in the Veeam VMware PowerPivot Example workbook display tables and charts that by default are configured to show datastore performance metrics and the DiskSize datastore property values. You can edit fields and change filters applied to the tables and charts to meet your specific needs.

note Note

When you import statistics from your own Data Warehouse, performance tables and charts on the spreadsheets may show no data. To resolve the issue, simply select another point in time in the DateTime field.

Pivot Table SCOM Example

PerfChart

PerfTable

Datastores with Disk Size Pivot

DS with DiskSize Power View


Pivot Table SCOM Example

Change data collection interval and choose objects to be displayed in the table to track performance statistics for different infrastructure objects.

Pivot Table SCOM Example


PerfChart

Change data collection interval, choose other objects to be displayed and switch between different object types to see how performance metric values have been changing during the selected time period.


PerfTable

Change data collection interval, choose other objects to be displayed and switch between different object types to see how average performance metric values have been changing during the selected time period.


Datastores with Disk Size Pivot

Change data collection interval, select a performance metric and choose objects to be displayed in the table to track performance statistics for different infrastructure objects and to show performance charts for them.

Datastores with Disk Size Pivot Example


DS with DiskSize Power View

Choose performance metrics to be displayed in the table and select a point in time when statistics on the selected metrics were collected to track datastore performance and the DiskSize datastore property values.

note Note

You can easily choose other performance metrics, but you cannot add another object property.

DS with DiskSize Power View Example


Veeam MP for VMware Reference

The Veeam MP for VMware Reference provides a full reference for all Veeam MP classes, properties and monitor property overrides, discoveries, rules and monitors for VMware events, as well as Veeam MP for VMware metric definitions.


Veeam MP for Hyper-V Reference

The Veeam MP for Hyper-V Reference provides a full reference for all Veeam MP classes, properties, discoveries, rules and monitors, as well as Veeam MP for Hyper-V metric definitions.


MP for Veeam Backup & Replication Reference

 Top Previous

The MP for Veeam Backup & Replication Reference provides a full reference for Management Pack for Veeam Backup & Replication classes, properties, discoveries, rules and monitors, as well as MP for Veeam Backup metric definitions.


vcEventsDoc

 Top

• Event AccountCreatedEvent

This event records that an account was created on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AccountRemovedEvent

This event records that an account was removed from a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AccountUpdatedEvent

This event records that an account was updated on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ad.event.ImportCertEvent

Import certificate succeeded

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.ImportCertFailedEvent

Import certificate failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.JoinDomainEvent

Join domain succeeded

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.JoinDomainFailedEvent

Join domain failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.LeaveDomainEvent

Leave domain succeeded

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event ad.event.LeaveDomainFailedEvent

Leave domain failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event AdminPasswordNotChangedEvent

Default password for the Admin user on the host has not been changed.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event AlarmAcknowledgedEvent

Alarm acknowledged

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event AlarmActionTriggeredEvent

This event records that an alarm was triggered.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmClearedEvent

Alarm cleared manually

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event AlarmCreatedEvent

This event records the creation of an alarm.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmEmailCompletedEvent

This event records the completion of an alarm email notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmEmailFailedEvent

This event records a failure to complete an alarm email notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmReconfiguredEvent

This event records the reconfiguration of an alarm.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmRemovedEvent

This event records the removal of an alarm.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmScriptCompleteEvent

This event records the completion of an alarm-triggered script.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmScriptFailedEvent

This event records a failure to complete an alarm-triggered script.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmSnmpCompletedEvent

This event records the completion of an alarm SNMP notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmSnmpFailedEvent

This event records a failure to complete an alarm SNMP notification.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AlarmStatusChangedEvent

This event records that an entity (such as a host or VM) has changed its overall status because an alarm was triggered. The event will show which entity and will indicate which alarm was triggered.

A host's or VM's alarm status changing from "green"/ "yellow" / "red" to "gray" may indicate that the host or VM has been shutdown.

If the alarm status is "yellow" or "red" then the icons in the VI Client will change.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event AllVirtualMachinesLicensedEvent

This event records that the previously unlicensed virtual machines on the specified host are now licensed. After this event is entered into the event log, we expect to see that the configuration issue removed from the host managed object.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event AlreadyAuthenticatedSessionEvent

This event records a failed user logon due to the user already being logged on.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event BadUsernameSessionEvent

This event records a failed user logon. Failed logons are due to no match existing between the provided user name and password combination and the combinations stored for authentication.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CanceledHostOperationEvent

An operation performed on the host was canceled. Typically, a previous event in the sequence of events contains more information about the cause of this cancellation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ChangeOwnerOfFileEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event ChangeOwnerOfFileFailedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event ClusterComplianceCheckedEvent

This event records that a compliance check was triggered on the cluster.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ClusterCreatedEvent

This event records when a cluster is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterDestroyedEvent

This event records when a cluster is destroyed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterOvercommittedEvent

This event records when a cluster's host capacity cannot satisfy resource configuration constraints.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterReconfiguredEvent

This event records when a cluster is reconfigured.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ClusterStatusChangedEvent

This event records when a cluster's overall status changed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.AddLicenseEvent

Added License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.AssignLicenseEvent

Assigned License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.DLFDownloadFailedEvent

Download License Information

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseAssignFailedEvent

License assignment faults

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseCapacityExceededEvent

License usage exceeds the license capacity

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseExpiryEvent

License Expiry

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.LicenseUserThresholdExceededEvent

License User Threshold Exceeded

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.license.RemoveLicenseEvent

Removed License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.license.UnassignLicenseEvent

Unassigned License

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.cim.CIMGroupHealthStateChanged

Hardware Health Changed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.datastore.UpdatedVmFilesEvent

Updated VM files

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.datastore.UpdateVmFilesFailedEvent

Failed to update VM files

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.datastore.UpdatingVmFilesEvent

Updating VM Files

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.dvs.LacpConfigInconsistentEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ft.VmAffectedByDasDisabledEvent

VMware HA has been disabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.guestOperations.GuestOperation

Guest operation performed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.guestOperations.GuestOperationAuthFailure

Authentication failed for guest operation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AllHostAddrsPingable

All vSphere HA isolation addresses are reachable by host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AllIsoAddrsPingable

All vSphere HA isolation addresses are reachable by host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AnsweredVmLockLostQuestionEvent

Lock-lost question was answered by vSphere HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AnsweredVmTerminatePDLEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.AutoStartDisabled

The automatic Virtual Machine Startup/Shutdown feature has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.CannotResetVmWithInaccessibleDatastore

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.ClusterContainsIncompatibleHosts

vSphere HA Cluster contains ESX/ESXi 3.5 hosts and more recent host versions, which isn't fully supported.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.ClusterFailoverActionCompletedEvent

HA completed a failover action

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.ClusterFailoverActionInitiatedEvent

HA initiated a failover action

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasAgentRunningEvent

HA Agent is running

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostFailedEvent

HA failover host has failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostIsolatedEvent

Host has been isolated from cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostPartitionedEvent

Failover Host is in a different network partition than the master

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasFailoverHostUnreachableEvent

The vSphere HA agent on the failover host is not reachable from vCenter Server

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostCompleteDatastoreFailureEvent

Host complete datastore failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostCompleteNetworkFailureEvent

Host complete network failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostFailedEvent

A possible host failure has been detected by HA

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostIsolatedEvent

Host has been isolated from cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasHostMonitoringDisabledEvent

No virtual machine failover will occur until Host Monitoring is enabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.DasTotalClusterFailureEvent

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.FailedRestartAfterIsolationEvent

Failed to restart VM after isolation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HeartbeatDatastoreChanged

Datastore heartbeat changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HeartbeatDatastoreNotSufficient

Number of heartbeat datastores is less than required

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostAgentErrorEvent

Host HA Agent has an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostDasAgentHealthyEvent

HA Agent on host is healthy

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostDasErrorEvent

Host HA has an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostDoesNotSupportVsan

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostHasNoIsolationAddrsDefined

Host has no isolation addresses defined as required by vSphere HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostHasNoMountedDatastores

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostHasNoSslThumbprint

vSphere HA cannot be configured because its SSL thumbprint has not been verified

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostIncompatibleWithHA

The product version of host is incompatible with HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostPartitionedFromMasterEvent

Host is in a different network partition than the master

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostStateChangedEvent

Host HA state has changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostUnconfiguredWithProtectedVms

Host with protected VMs is disconnected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.HostUnconfigureError

Error unconfiguring HA agent on host. To solve this problem, connect the host to a vCenter Server of version 5.0 or later.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.InvalidMaster

HA Agent on host is an invalid master

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.NotAllHostAddrsPingable

Host HA Agent cannot reach some of the management network addresses of other hosts

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.StartFTSecondaryFailedEvent

Host HA agent failed to start Fault Tolerance secondary VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.StartFTSecondarySucceededEvent

Host HA agent successfully started Fault Tolerance secondary VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.UserHeartbeatDatastoreRemoved

Datastore is removed from inventory

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VcCannotFindMasterEvent

vCenter Server is unable to find a master vSphere HA Agent

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VcConnectedToMasterEvent

vCenter Server is connected to the master vSphere HA Agent

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VcDisconnectedFromMasterEvent

vCenter Server is disconnected from the master vSphere HA Agent

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VMIsHADisabledIsolationEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VMIsHADisabledRestartEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmNotProtectedEvent

VM failed to become vSphere HA Protected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmProtectedEvent

VM is vSphere HA Protected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ha.VmRestartedByHAEvent

VM was restarted by HA

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmUnprotectedEvent

VM is not HA Protected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.HA.VmUnprotectedOnDiskSpaceFull

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.AutoStartReconfigureFailedEvent

Failed to reconfigure autostart rules for virtual machines

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.clear.vFlashResource.inaccessible

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.clear.vFlashResource.reachthreshold

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.problem.vFlashResource.inaccessible

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.problem.vFlashResource.reachthreshold

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.defaultModuleChangedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.modulesLoadedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.SsdConfigurationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.VFlashResourceCapacityExtendedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.VFlashResourceConfiguredEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.host.vFlash.VFlashResourceRemovedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.npt.VmAdapterEnteredPassthroughEvent

Virtual NIC entered passthrough mode

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.npt.VmAdapterExitedPassthroughEvent

Virtual NIC exited passthrough mode

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.CloneOvfConsumerStateErrorEvent

Failed to clone extension entity state

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.GetOvfEnvironmentSectionsErrorEvent

Failed to retrieve OVF environment sections from extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.PowerOnAfterCloneErrorEvent

Extension has blocked powering on of cloned VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.RegisterEntityErrorEvent

Failed to register entity on extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.UnregisterEntitiesErrorEvent

Failed to unregister entities on extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.ovfconsumers.ValidateOstErrorEvent

Failed to validate OVF descriptor on extension

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.profile.AnswerFileExportedEvent

Answer file has been exported

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.profile.AnswerFileUpdatedEvent

Answer file has been updated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.rp.ResourcePoolRenamedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.CanceledDatastoreMaintenanceModeEvent

The datastore maintenance mode operation has been canceled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.ConfiguredStorageDrsOnPodEvent

Storage DRS configured on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.ConsistencyGroupViolationEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreEnteredMaintenanceModeEvent

Datastore has entered maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreEnteringMaintenanceModeEvent

Datastore is entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreExitedMaintenanceModeEvent

Datastore has exited maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreInMultipleDatacentersEvent

Datastore cluster has one or more datastores shared across multiple datacenters

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.DatastoreMaintenanceModeErrorsEvent

Datastore encountered errors while entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsDisabledEvent

Storage DRS disabled on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsEnabledEvent

Storage DRS enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsInvocationFailedEvent

Storage DRS invocation failed on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsNewRecommendationPendingEvent

A new storage DRS recommendation has been generated on datastore cluster

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsNotSupportedHostConnectedToPodEvent

Datastore cluster is connected to one or more hosts that do not support storage DRS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsRecommendationApplied

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsStorageMigrationEvent

VM disks migrated by storage DRS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StorageDrsStoragePlacementEvent

Storage DRS placed disks of VM on specified datastore

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StoragePodCreatedEvent

Datastore cluster created

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sdrs.StoragePodDestroyedEvent

Datastore cluster removed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sioc.NotSupportedHostConnectedToDatastoreEvent

SIOC has detected that a host is running an older version of ESX that does not support SIOC

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.datastore.ComplianceStatusCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.datastore.ComplianceStatusNonCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.datastore.ComplianceStatusUnknownEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.LunCapabilityInitEvent

Storage provider system default capability event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.LunCapabilityMetEvent

Storage provider system capability requirements met

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.LunCapabilityNotMetEvent

Storage provider system capability requirements not met

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.provider.health.event

SMS Provider health event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.provider.system.event

SMS Provider system event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.ThinProvisionedLunThresholdClearedEvent

Storage provider thin provisioning capacity threshold reached

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.ThinProvisionedLunThresholdCrossedEvent

Storage provider thin provisioning capacity threshold crossed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.ThinProvisionedLunThresholdInitEvent

Storage provider thin provisioning default capacity event

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.vm.ComplianceStatusCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.vm.ComplianceStatusNonCompliantEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.sms.vm.ComplianceStatusUnknownEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.spbm.ProfileAssociationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.stats.HostQuickStatesNotUpToDateEvent

Host quick stats is not up-to-date

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VCHealthStateChangedEvent

vCenter Service Overall Health Changed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtDisabledVmTreatAsNonFtEvent

HA VM Component Protection protects virtual machine as non-FT virtual machine because the FT state is disabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtFailoverEvent

FT Primary VM is going to fail over to Secondary VM due to component failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtFailoverFailedEvent

FT virtual machine failed to failover to secondary

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtSecondaryRestartEvent

HA VM Component Protection is restarting FT secondary virtual machine

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.FtSecondaryRestartFailedEvent

FT Secondary VM failed to restart

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.NeedSecondaryFtVmTreatAsNonFtEvent

HA VM Component Protection protects virtual machine as non-FT virtual machine because it has been in the needSecondary state too long

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.TestEndEvent

VM Component Protection test ends

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.TestStartEvent

VM Component Protection test starts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VcpNoActionEvent

HA VM Component Protection did not take action on VM

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmDatastoreFailedEvent

Virtual machine lost datastore access

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmNetworkFailedEvent

Virtual machine lost VM network accessibility

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmPowerOffHangEvent

VM power off hang

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmRestartEvent

HA VM Component Protection is restarting virtual machine due to component failure

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmRestartFailedEvent

Virtual machine affected by component failure failed to restart

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vcp.VmWaitForCandidateHostEvent

No candidate host to restart

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vm.VmRegisterFailedEvent

VM registration failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vm.VmStateFailedToRevertToSnapshot

Failed to revert the execution state of the virtual machine to snapshot

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vm.VmStateRevertedToSnapshot

The execution state of the virtual machine has been reverted to the state of snapshot

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.AppMonitoringNotSupported

Application monitoring is not supported

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.VmAppHealthMonitoringStateChangedEvent

Application heartbeat status changed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.VmAppHealthStateChangedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vmam.VmDasAppHeartbeatFailedEvent

Application heartbeat failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmCloneFailedInvalidDestinationEvent

Cannon clone a VM to invalid or non-existent destination

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmCloneToResourcePoolFailedEvent

Cannot clone a VM to resource pool

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskConsolidatedEvent

VM disks successfully consolidated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskConsolidationNeeded

VM disks consolidation is needed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskConsolidationNoLongerNeeded

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.VmDiskFailedToConsolidateEvent

VM disks consolidation failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.DatastoreNoCapacityEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostCommunicationErrorEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostNotInClusterEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostNotInVsanClusterEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderDeregistrationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderDeregistrationSuccessEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderRegistrationFailedEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.HostVendorProviderRegistrationSuccessEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.NetworkMisConfiguredEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vc.vsan.RogueHostFoundEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.create

EAM Agency created

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.destroyed

EAM Agency destroyed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.goalstate

EAM Agency goal state changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.statusChanged

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agency.updated

EAM Agency configuration updated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.created

EAM Agent added to host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.destroyed

EAM Agent removed from host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.destroyedNoHost

EAM Agent removed from host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterPowerOn

Agent VM has been powered on.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.markAgentVmAsAvailableAfterProvisioning

Agent VM has been powered on.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.statusChanged

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.deleteVm

Agent VM is deleted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.deployVm

Agent VM is provisioned

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.powerOffVm

Agent VM powered off

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.powerOnVm

Agent VM powered on

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.vibInstalled

VIB installed on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.agent.task.vibUninstalled

VIB unistalled from host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.cannotAccessAgentOVF

Unable to access agent OVF package

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.cannotAccessAgentVib

Unable to access agent VIB module

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.hostInMaintenanceMode

Agent cannot complete an operation since the host is in maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.hostInStandbyMode

Agent cannot complete an operation since the host is in standby mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.hostPoweredOff

Agent cannot complete an operation since the host is powered off

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.incompatibleHostVersion

Agent is not deployed due to incompatible host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.insufficientIpAddresses

Insufficient IP addresses in IP pool in agent's VM network

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.insufficientResources

Agent cannot be provisioned due to insufficient resources on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.insufficientSpace

Agent on cannot be provisioned due to insufficient space on datastore

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.missingAgentIpPool

No IP pool in agent's VM network

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.missingDvFilterSwitch

dvFilter switch is not configured

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noAgentVmDatastore

No agent datastore configuration

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noAgentVmNetwork

No agent network configuration

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noCustomAgentVmDatastore

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.noCustomAgentVmNetwork

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.orphandedDvFilterSwitch

Unused dvFilter switch

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.orphanedAgency

Orphaned agency found

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.ovfInvalidFormat

OVF used to provision agent has invalid format

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.ovfInvalidProperty

OVF environment has one or more invalid properties

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.resolved

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.unknownAgentVm

Unknown agent VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibCannotPutHostInMaintenanceMode

Cannot put host into maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibInvalidFormat

Invalid format for VIB module

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibNotInstalled

VIB module for agent is not installed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresHostInMaintenanceMode

Host must be put into maintenance mode to complete agent VIB installation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresHostReboot

Host must be rebooted to complete agent VIB installation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresManualInstallation

VIB requires manual installation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vibRequiresManualUninstallation

VIB requires manual uninstallation

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmCorrupted

Agent VM is corrupted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmDeployed

Agent VM is provisioned on host when it should be removed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmMarkedAsTemplate

Agent VM is marked as template

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmNotDeployed

Agent VM is missing on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmOrphaned

Orphaned agent VM detected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmPoweredOff

Agent VM is expected to be powered on

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmPoweredOn

Agent VM is expected to be powered off

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmSuspended

Agent VM is expected to be powered on but is suspended

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmWrongFolder

Agent VM is in the wrong VM folder

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.issue.vmWrongResourcePool

Agent VM is in wrong resource pool

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.login.invalid

Failed login to vSphere ESX Agent Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.login.succeeded

User logged into vSphere ESX Agent Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.logout

User logged out of vSphere ESX Agent Manager by logging out of the vCenter server

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.scanForUnknownAgentVmsCompleted

Scan for unknown agent VMs completed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.scanForUnknownAgentVmsInitiated

Scan for unknown agent VMs initiated

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.setupDvFilter

DvFilter switch is setup on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.task.tearDownDvFilter

DvFilter switch is teared down on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.unauthorized.access

Unauthorized access in vSphere ESX Agent Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.eam.vum.failedtouploadvib

Failed to upload VIB to VMware Update Manager

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.bind.vApp

VSM Dependecy bind - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.bind.vm

VSM Dependecy bind - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.create.vApp

VSM Dependecy create - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.create.vm

VSM Dependecy create - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.destroy.vApp

VSM Dependecy destroy - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.destroy.vm

VSM Dependecy destroy - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.reconfigure.vApp

VSM Dependecy reconfigure - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.reconfigure.vm

VSM Dependecy reconfigure - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.unbind.vApp

VSM Dependecy unbind - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.unbind.vm

VSM Dependecy unbind - VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.update.vApp

VSM Dependecy update - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.dependency.update.vm

VSM Dependecy update - vApp

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.provider.register

VSM Provider register

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.provider.unregister

VSM Provider unregister

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event com.vmware.vim.vsm.provider.update

VSM Provider update

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefAddedEvent

This event records the addition of a custom field definition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefEvent

This event records a custom field definition event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefRemovedEvent

This event records the removal of a custom field definition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldDefRenamedEvent

This event records the renaming of a custom field definition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomFieldValueChangedEvent

This event records a change to a custom field value for a particular entity.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event CustomizationFailed

The customization sequence completed unsuccessfully in the guest.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationLinuxIdentityFailed

Failed to set Linux identity. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationNetworkSetupFailed

Network setup failed in the guest during customization. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationStartedEvent

The customization sequence has started in the VM guest.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationSucceeded

The customization sequence completed successfully in the guest.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationSysprepFailed

Sysprep failed to run in the guest during customization. This will most like have been caused by the fact that the wrong sysprep was used for the guest, so we include the version information in the event. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event CustomizationUnknownFailure

The customization sequence failed unexpectedly in the guest. Refer to the log file specified in the event message for more information.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DasAdmissionControlDisabledEvent

This event records when admission control checks have been disabled in a HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasAdmissionControlEnabledEvent

This event records when admission control checks have been enabled in a HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasAgentFoundEvent

This event records that vCenter has re-established contact with a primary host in this HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasAgentUnavailableEvent

This event records that vCenter cannot contact any primary host in this HA cluster. HA designates some hosts as primary hosts in the HA cluster. When adding a new host to an existing cluster, HA needs to contact one of the primary hosts to finish the configuration. vCenter has lost contact with all primary nodes in the connected state. Attempts to configure HA on a host in this cluster will fail until a DasAgentFoundEvent is logged or unless this is the first node to be configured. For example, if all the other hosts are disconnected first.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasClusterIsolatedEvent

This event records that all hosts have been isolated from the network in a HA cluster.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DasDisabledEvent

This event records when a cluster has been disabled for HA.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasEnabledEvent

This event records when a cluster has been enabled for HA.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasHostFailedEvent

This event records when a host failure has been detected by HA.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DasHostIsolatedEvent

This event records that a host has been isolated from the network in a HA cluster. Since an isolated host cannot be distinguished from a failed host except by the isolated host itself, this event is logged when the isolated host regains network connectivity.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatacenterCreatedEvent

This event records when a datacenter object has been created.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DatacenterRenamedEvent

This event is generated whenever a datacenter is renamed.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DatastoreCapacityIncreasedEvent

This event records when increase in a datastore's capacity is observed. It may happen due to different reasons, like extending or expanding a datastore.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreDestroyedEvent

This event records when a datastore is removed from vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreDiscoveredEvent

This event records when a host is added to vCenter and datastores are discovered.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreDuplicatedEvent

This event records when a duplicate datastore name is found. This event is used in vCenter 1.x and is included for backward compability.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreFileCopiedEvent

This event records copy of a file or directory.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreFileDeletedEvent

This event records deletion of a file or directory.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreFileMovedEvent

This event records move of a file or directory.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DatastoreIORMReconfiguredEvent

This event records that the configuration of storage I/O resource management for a datastore has changed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DatastorePrincipalConfigured

This event records that a datastore principal was configured on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreRemovedOnHostEvent

This event records when a datastore is removed from a host but not from vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreRenamedEvent

This event records the renaming of a datastore.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DatastoreRenamedOnHostEvent

This event records when a datastore is added to vCenter and is renamed by vCenter because this datastore already exists in vCenter with a different name, or because the name conflicts with another datastore in vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsDisabledEvent

This event records when DRS is disabled on a cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsEnabledEvent

This event records when DRS is enabled on a cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsEnteredStandbyModeEvent

This event records that the host has completely put into standby mode by Distributed Power Management. A host in this mode has no running virtual machines and no provisioning operations are occurring.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DrsEnteringStandbyModeEvent

This event records that a host has begun the process of entering standby mode initiated by Distributed Power Management.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsExitedStandbyModeEvent

This event records that Distributed Power Management has brought this host out of standby mode.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DrsExitingStandbyModeEvent

This event records that a host has begun the process of exiting standby mode initiated by Distributed Power Management.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsExitStandbyModeFailedEvent

This event records that Distributed Power Managment tried to bring a host out from standby mode, but the host failed to exit standby mode.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsInvocationFailedEvent

This event records DRS invocation failure.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsRecoveredFromFailureEvent

This event records that DRS has recovered from failure. It is triggered by a successful DRS invocation after repeated failure.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DrsResourceConfigureFailedEvent

This event records when resource configuration specification synchronization fails on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsResourceConfigureSyncedEvent

This event records when resource configuration specification returns to synchronized from previous failure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsRuleComplianceEvent

This event records when a virtual machine comes into compliance with DRS rules

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DrsRuleViolationEvent

This event records when a virtual machine violates a DRS rule

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DrsVmMigratedEvent

This event records a virtual machine migration that was recommended by DRS.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event DrsVmPoweredOnEvent

This event records when a virtual machine is powered on by DRS.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DuplicateIpDetectedEvent

This event records that a duplicate IP address has been observed in conflict with the vmotion or IP storage interface configured on the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event DvpgImportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvpgRestoreEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DVPortgroupCreatedEvent

Distributed virtual portgroup was created

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DVPortgroupDestroyedEvent

Distributed virtual portgroup was destroyed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DVPortgroupReconfiguredEvent

Distributed virtual portgroup was reconfigured

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DVPortgroupRenamedEvent

Distributed virtual portgroup was renamed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsCreatedEvent

A distributed virtual switch was created

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsDestroyedEvent

A distributed virtual switch was destroyed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsEvent

These are dvs-related events.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHealthStatusChangeEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvsHostBackInSyncEvent

The DVS configuration on the host was synchronized with that of the vCenter Server and the configuration is the same on the host and vCenter Server.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHostJoinedEvent

A host joined the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHostLeftEvent

A host left the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsHostStatusUpdated

A host has it's status or statusDetail updated

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DvsHostWentOutOfSyncEvent

The DVS configuration on the host diverged from that of the Virtual Center Server.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsImportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvsMergedEvent

Two distributed virtual switches was merged.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortBlockedEvent

A port is blocked in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortConnectedEvent

A port is connected in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortCreatedEvent

New ports are created in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortDeletedEvent

Existing ports are deleted in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortDisconnectedEvent

A port is disconnected in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortEnteredPassthruEvent

A port has entered passthrough mode on the distributed virtual switch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DvsPortExitedPassthruEvent

A port has exited passthrough mode on the distributed virtual switch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event DvsPortJoinPortgroupEvent

A port was moved into the distributed virtual portgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortLeavePortgroupEvent

A port was moved out of the distributed virtual portgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortLinkDownEvent

A port of which link status is changed to down in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortLinkUpEvent

A port of which link status is changed to up in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortReconfiguredEvent

Existing ports are reconfigured in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortRuntimeChangeEvent

DVS runtime information changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event DvsPortUnblockedEvent

A port is blocked in the distributed virtual switch.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsPortVendorSpecificStateChangeEvent

Vendor specific state changed in the DVS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event DvsReconfiguredEvent

A distributed virtual switch was reconfigured.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsRenamedEvent

A distributed virtual switch was renamed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsRestoreEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event DvsUpgradeAvailableEvent

An upgrade for the distributed virtual switch is available.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsUpgradedEvent

The distributed virtual switch was upgraded.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsUpgradeInProgressEvent

An upgrade for the distributed virtual switch is in progress.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event DvsUpgradeRejectedEvent

An upgrade for the distributed virtual switch is rejected.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event EnteredMaintenanceModeEvent

This event records that the host has completely entered maintenance mode. A host in this mode has no running virtual machines and no provisioning operations are occuring.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event EnteredStandbyModeEvent

This event records that the host has completely entered standby mode. A host in this mode has no running virtual machines and no provisioning operations are occurring.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event EnteringMaintenanceModeEvent

This event records that a host has begun the process of entering maintenance mode. All virtual machine operations are blocked, except for the following:

· MigrateVM
· PowerOffVM
· SuspendVM
· ShutdownGuest
· StandbyGuest

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event EnteringStandbyModeEvent

This event records that a host has begun the process of entering standby mode. All virtual machine operations are blocked, except for the following:

· MigrateVM
· PowerOffVM
· SuspendVM
· ShutdownGuest
· StandbyGuest

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event ErrorUpgradeEvent

This event is a general error event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.defaults.factoryrestore

The host has been restored to default factory settings

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.disabled

The DCUI has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.enabled

The DCUI has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.host.reboot

The host is being rebooted through the Direct Console User Interface (DCUI)

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.host.shutdown

The host is being shut down through the Direct Console User Interface (DCUI)

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.hostagents.restart

The management agents on the host are being restarted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.login.failed

Authentication has failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.login.passwd.changed

Login password has been changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.network.factoryrestore

The host has been restored to factory network settings

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.dcui.network.restart

A management interface has been restarted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esxcli.host.poweroff

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.esxcli.host.restart

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.hostacceptance.changed

Host acceptance level changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.install.novalidation

Attempting to install an image profile with validation disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.install.securityalert

SECURITY ALERT: Installing image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.profile.install.successful

Successfully installed image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.profile.update.successful

Successfully updated host to image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.vib.install.successful

Successfully installed VIBs

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.esximage.vib.remove.successful

Successfully removed VIBs

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.host.boot

Host has booted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.host.maxRegisteredVMsExceeded

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.host.stop.reboot

Host is rebooting

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.host.stop.shutdown

Host is shutting down

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.lockdownmode.disabled

Administrator access to the host has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.lockdownmode.enabled

Administrator access to the host has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.canceled

The host has canceled entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.entered

The host has entered maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.entering

The host has begun entering maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.maintenancemode.exited

The host has exited maintenance mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.config.changed

Firewall configuration has changed.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.disabled

Firewall has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.enabled

Firewall has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.port.hooked

Port is now protected by Firewall

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.firewall.port.removed

Port is no longer protected with Firewall.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.lacp.disable

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.net.lacp.enable

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.net.lacp.uplink.connected

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.audit.net.vdl2.ip.change

VDL2 IP changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.vdl2.mappingtable.full

Mapping table entries of VDL2 network exhausted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.net.vdl2.route.change

VDL2 IP interface default route changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.shell.disabled

The ESX command line shell has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.shell.enabled

The ESX command line shell has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.ssh.disabled

SSH access has been disabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.ssh.enabled

SSH access has been enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.usb.config.changed

USB configuration has changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.uw.secpolicy.alldomains.level.changed

The enforcement level for all security domains has been changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.uw.secpolicy.domain.level.changed

The enforcement level for security domain has been changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vmfs.lvm.device.discovered

One or more LVM devices have been discovered

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vmfs.volume.mounted

File system has been mounted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vmfs.volume.umounted

The volume has been safely un-mounted

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.audit.vsan.clustering.enabled

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.coredump.configured

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.connectivity.restored

Restored network connectivity to portgroups

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.dvport.connectivity.restored

Restored Network Connectivity to DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.dvport.redundancy.restored

Restored Network Redundancy to DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.lacp.lag.transition.up

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.net.lacp.uplink.transition.up

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.lacp.uplink.unblocked

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.redundancy.restored

Restored uplink redundancy to portgroups

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.net.vmnic.linkstate.up

Link state up

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.scsi.device.io.latency.improved

Device performance has improved

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.clear.scsi.device.state.on

Device has been turned on administratively

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.clear.scsi.device.state.permanentloss.deviceonline

Device that was permanently inaccessible is now online. No data consistency guarantees

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.clear.storage.apd.exit

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.clear.storage.connectivity.restored

Restored connectivity to storage device

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.storage.redundancy.restored

Restored path redundancy to storage device

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.clear.vsan.clustering.enabled

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.vsan.network.available

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.clear.vsan.vmknic.ready

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.3rdParty.error

A 3rd party component running on ESXi has reported an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.3rdParty.info

A 3rd party component running on ESXi has reported an info message

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.3rdParty.warning

A 3rd party component running on ESXi has reported a warning

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.memory.error.corrected

A corrected memory error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.memory.error.fatal

A fatal memory error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.memory.error.recoverable

A recoverable memory error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.pcie.error.corrected

A corrected PCIe error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.pcie.error.fatal

A fatal PCIe error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.apei.bert.pcie.error.recoverable

A recoverable PCIe error occurred

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.application.core.dumped

An application running on ESXi host has crashed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.coredump.unconfigured

No vmkcore disk partition is available and no network coredump server has been configured. Host core dumps cannot be saved.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.amd.mce.dram.disabled

DRAM ECC not enabled

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.intel.ioapic.listing.error

Not all IO-APICs are listed in the DMAR

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.mce.invalid

MCE monitoring will be disabled as an unsupported CPU was detected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.smp.ht.invalid

Disabling HyperThreading due to invalid configuration

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.smp.ht.numpcpus.max

CPU limit reached

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.cpu.smp.ht.partner.missing

Disabling HyperThreading due to invalid configuration: HT partner is missing from PCPU

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.dhclient.lease.none

Unable to obtain a DHCP lease

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.dhclient.lease.offered.error

dhclient reported an error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.dhclient.lease.persistent.none

No working DHCP leases in persistent database

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.esximage.install.error

Image profie could not be installed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.esximage.install.invalidhardware

Host doesn't meet hardware requirements

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.esximage.install.stage.error

Could not stage image profile

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hardware.acpi.interrupt.routing.device.invalid

BIOS bug, skipping interrupt routing entry with bad device number

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hardware.acpi.interrupt.routing.pin.invalid

BIOS bug, skipping interrupt routing entry with bad device pin

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hardware.ioapic.missing

IOAPIC is missing. Please check BIOS settings.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.host.coredump

An unread host kernel core dump has been found

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.hostd.core.dumped

hostd crashed with a core file created

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.iorm.badversion

Host cannot participate in SIOC because of incompatible version number

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.iorm.nonviworkload

External/Uncontrolled workload detected on a datastore

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.migrate.vmotion.default.heap.create.failed

Default migration heap creation failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.migrate.vmotion.server.pending.cnx.listen.socket.shutdown

The ESXi host's vMotion network server encountered an error while monitoring incoming network connections. Shutting down listener socket. vMotion might not be possible with this host until vMotion is manually re-enabled.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.connectivity.lost

Network connectivity lost on vSwitch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.dvport.connectivity.lost

Network connectivity lost on DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.dvport.redundancy.degraded

Network Redundancy Degraded on DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.dvport.redundancy.lost

Network Redundancy Lost on DVPorts

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.e1000.tso6.notsupported

Guest-initiated IPv6 TCP Segmentation Offload (TSO) packets ignored. Manually disable TSO inside the guest operating system, or use a different virtual adapter.

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.fence.port.badfenceid

VMkernel failed to set fenceId

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.fence.resource.limited

Maximum number of fence networks or ports have been reached

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.fence.switch.unavailable

dvSwitch fence property is not set

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.firewall.config.failed

Firewall configuration failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.firewall.port.hookfailed

Adding port to Firewall failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.gateway.set.failed

Cannot connect to the specified gateway

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.heap.belowthreshold

Heap free size dropped

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.lag.transition.down

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.peer.noresponse

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.policy.incompatible

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.policy.linkstatus

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.blocked

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.disconnected

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.fail.duplex

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.fail.speed

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.inactive

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.lacp.uplink.transition.down

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.migrate.bindtovmk

Invalid vmknic specified in the ESX configuration

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.migrate.unsupported.latency

High vMotion network latency detected

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.portset.port.full

Maximum number of ports has been reached. Cannot apply for any more free ports.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.portset.port.vlan.invalidid

Invalid VLANID. VLAN ID must be between 0 and 4095.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.proxyswitch.port.unavailable

Virtual NIC connection to switch failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.redundancy.degraded

Network redundancy degraded on vSwitch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.redundancy.lost

Network redundancy lost on vSwitch

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.uplink.mtu.failed

Failed to set MTU on an uplink

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.instance.initialization.fail

VDL2 instance initialization failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.instance.notexist

VDL2 overlay instance is not created on DVS

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.mcastgroup.fail

VDL2 IP interface on vmknic failed to join multicast group

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.network.initialization.fail

VDL2 network initialization failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.port.initialization.fail

VDL2 initialization failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.vmknic.fail

VDL2 IP interface failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vdl2.vmknic.notexist

VDL2 IP interface does not exist

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmknic.ip.duplicate

A duplicate IP address was detected on a vmknic interface

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmnic.linkstate.down

Link state down

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmnic.linkstate.flapping

NIC link is unstable. Taking down.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.net.vmnic.watchdog.reset

Nic Watchdog Reset

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.ntpd.clock.correction.error

NTP daemon stopped.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.platform.retire.request

Memory page retirement requested by platform firmware

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.host.exceeded

Number of host physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.kernel.exceeded

Number of kernel physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.userclient.exceeded

Number of physical memory pages belonging to (user) memroy client that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.userprivate.exceeded

Number of private user physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.usershared.exceeded

Number of shared user physical memory pages that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.pageretire.selectedmpnthreshold.vmmclient.exceeded

Number of physical memory pages belonging to (vmm) memroy client that have been selected for retirement exceeds threshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.apd.event.descriptor.alloc.failed

No memory to allocate APD (All Paths Down) event subsystem

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.close.failed

Failed to close the device properly

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.detach.failed

Exceeded the number of devices that can be detached, detach failed.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.filter.attach.failed

Failed to attach filters to device '%s' during registration. Plugin load failed or the filter rules are incorrect.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.bad.plugin.type

Bad plugin type for device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.inquiry.failed

Failed to get standard inquiry for device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.invalid.disk.qfull.value

QFullSampleSize should be bigger than QFullThreshold

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.latency.high

Device I/O latency increased

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.qerr.change.config

SCSI ChangeQErrSetting configuration value has been changed. This may cause unexpected behavior.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.io.qerr.changed

QErr configuration value has been changed. This may cause unexpected behavior.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.is.local.failed

Failed to verify if the device from plugin is a local - not shared - device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.is.pseudo.failed

Failed to verify if the device from plugin is a pseudo device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.is.ssd.failed

Failed to verify if the device from plugin is a Solid State Disk device

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.limitreached

The maximum number of supported devices has been reached

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.off

Device has been turned off administratively

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss

Device has been removed or is permanently inaccessible

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss.noopens

Permanently inaccessible device has no more opens

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss.pluggedback

Device has been plugged back in after being marked permanently inaccessible

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.state.permanentloss.withreservationheld

Device has been removed or is permanently inaccessible, while holding a reservation.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.device.thinprov.atquota

Thin Provisioned Device Nearing Capacity

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.scsipath.limitreached

Maximum number of storage paths

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.scsi.unsupported.plugin.type

Scsi Device Allocation not supported for plugin type

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.apd.start

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.apd.timeout

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.devicepor

Frequent PowerOn Reset Unit Attention of storage device

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.lost

Storage connectivity lost

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.pathpor

Frequent PowerOn Reset Unit Attention of Storage Path

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.connectivity.pathstatechanges

Frequent State Changes of Storage Path

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.discovery.connect.error

iSCSI discovery failed. The iSCSI Initiator could not establish a network connection to the discovery address.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.discovery.login.error

iSCSI discovery failed. The Discovery target returned a login error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.target.connect.error

Login to iSCSI target failed. The iSCSI initiator could not establish a network connection to the target

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.target.login.error

Login to iSCSI target failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.iscsi.target.permanently.lost

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.redundancy.degraded

Storage redundancy degraded

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.storage.redundancy.lost

Storage redundancy lost

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.syslog.config

System logging is not configured on host

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.syslog.nonpersistent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vfat.filesystem.full.other

The VFAT filesystem is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vfat.filesystem.full.scratch

The host's scratch partition, which is the VFAT filesystem, is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.failure

An operation on the root filesystem has failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.inodetable.full

The root filesystem's file table is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.ramdisk.full

The ramdisk is full

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.visorfs.ramdisk.inodetable.full

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.fault.failure

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.forcefulPageRetire

The VM contains host physical page which was scheduled for immediate retirement

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.noSwapResponse

The VM did not respond to swap actions and is forcefully powered off to prevent system instability

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vm.kill.unexpected.vmtrack

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.ats.support.lost

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.error.volume.is.locked

Volume is locked

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.extent.offline

Attached device is offline

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.extent.online

Backing file system came online

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.heartbeat.recovered

Access to volume successfully restored

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.heartbeat.timedout

Volume connectivity lost

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.heartbeat.unrecoverable

Volume connectivity lost and subsequent recovery attempts have failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.journal.createfailed

No space for journal. Opening volume in read-only metadata mode with limited write support.

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.lock.corruptondisk

Corrupt on-disk lock was detected on volume. Other regions of the volume might be damaged too.

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.mount.connect.failed

Unable to connect to NFS server

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.mount.limit.exceeded

NFS has reached the maximum number of supported volumes

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.server.disconnect

NFS Server disconnected

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.nfs.server.restored

NFS Server reconnected

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.resource.corruptondisk

Corrupt resource metadata region was detected

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmfs.volume.locked

Volume locked

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.remote.failure

Hose has become unreachable

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.storage.failure

Logging to storage has failed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.storage.logdir.invalid

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event esx.problem.vmsyslogd.unexpected

Log daemon has failed for an unexpected reason

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vpxa.core.dumped

Application crashed and a core file might have been created.

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.clustering.disabled

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.net.not.ready

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.net.redundancy.lost

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.net.redundancy.reduced

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.no.network.connectivity

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event esx.problem.vsan.vmknic.not.ready

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event ExitedStandbyModeEvent

This event records that the host is no longer in standby mode.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event ExitingStandbyModeEvent

This event records that a host has begun the process of exiting standby mode.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ExitMaintenanceModeEvent

This event records that the host is no longer in maintenance mode.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ExitStandbyModeFailedEvent

This event records that the host failed to exit standby mode.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event FailoverLevelRestored

This event records that the amount of cluster resources has increased and is now sufficient to satisfy the configured HA failover level.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralEvent

This is actually the base class for general events and should not be seen. The derived general events are the ones that will be generated. See VMware's documentation for the complete list of these events.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralHostErrorEvent

This event is the general error event for a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralHostInfoEvent

This event is the general information event for a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralHostWarningEvent

This event is the general warning event for a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralUserEvent

This event is the general user event type.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralVmErrorEvent

This event is the general error event for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralVmInfoEvent

This event is the general information event for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GeneralVmWarningEvent

This event is the general warning event for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event GhostDvsProxySwitchDetectedEvent

This event records when vCenter server found DVS proxy switches on the host that don't match any DVS defined in vCenter.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event GhostDvsProxySwitchRemovedEvent

This event records when the ghost DVS proxy switches (a.k.a host proxy switches that don't match any DVS defined in vCenter) were removed on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event GlobalMessageChangedEvent

This event records a change to the global message.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.AppQuiescedDeltaCompletedEvent

Application consistent delta completed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.ConnectionRestoredToHbrServerEvent

Connection to replication server restored for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.DeltaAbortedEvent

Delta aborted for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.DeltaCompletedEvent

Delta completed for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.DeltaStartedEvent

Delta for VM started

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.FailedToStartDeltaEvent

Failed to start delta for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.FailedToStartSyncEvent

Failed to start full sync for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.FSQuiescedDeltaCompletedEvent

File system consistent delta completed for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.InvalidDiskReplicationConfigurationEvent

VM replication configuration is invalid

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.InvalidVmReplicationConfigurationEvent

VM replication configuration is invalid

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.NoConnectionToHbrServerEvent

No connection to replication server

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.NoProgressWithHbrServerEvent

Replication server error

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.QuiesceNotSupported

Quiescing is not supported for VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.SyncCompletedEvent

VM full sync completed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.SyncStartedEvent

Full sync started for VM

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.UnquiescedDeltaCompletedEvent

Delta completed for virtual machine

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event hbr.primary.VmReplicationConfigurationChangedEvent

VM replication configuration changed

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event HealthStatusChangedEvent

Event used to report change in health status of vCenter components.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostAddedEvent

This event records the addition of a host to vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostAddFailedEvent

This event records that adding a host failed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostAdminDisableEvent

This event records that the permission on the host has been changed such that only the user account used for vCenter operation will have Administrator permission.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostAdminEnableEvent

This event records that the administrator permission has been restored.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostCnxFailedAccountFailedEvent

This event records a failure to connect to a host due to a failure to set up a management account.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedAlreadyManagedEvent

This event records a failure to connect to a host due to the host being managed by a different vCenter server.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedBadCcagentEvent

This event records a failure to connect to a host due to no response being received from the host agent.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedBadUsernameEvent

This event records a failure to connect to a host due to an invalid user name and password combination.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedBadVersionEvent

This event records a failure to connect to a host due to an incompatible client version.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedCcagentUpgradeEvent

This event records a failure to connect to a host due to a conflict with an upgrade or installation of the host agent.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedEvent

This event records a failure to connect to a host due to an unspecified condition.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNetworkErrorEvent

This event records a failure to connect to a host due to a network error.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNoAccessEvent

This event records a failure to connect to a host due to insufficient account privileges.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNoConnectionEvent

This event records a failure to connect to a host due to a host not being present on the network.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNoLicenseEvent

This event records a failure to connect to a host due to a licensing issue.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedNotFoundEvent

This event records a failure to connect to a host due to a failure to resolve the host name.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostCnxFailedTimeoutEvent

This event records a failure to connect to a host due to a timeout on the connection attempt.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostComplianceCheckedEvent

This event records that a compliance check was triggered on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostCompliantEvent

This event records that host is in compliance.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostConfigAppliedEvent

This event records that a configuration was applied on a host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostConnectedEvent

This event records a successful host connection. After this event is generated, there will also be a VmConnectedEvent generated for each VM on the host, regardless of the VM's power state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostConnectionLostEvent

This event records the (unexpected) loss of a host connection. This might occur if a ESX system was powered down, for example. After this event is generated, there will also be a VmDisconnectedEvent generated for each VM on the host, regardless of the VM's power state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasDisabledEvent

This event records when HA has been disabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasDisablingEvent

This event records when HA is being disabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasEnabledEvent

This event records when HA has been enabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasEnablingEvent

This event records when HA has been enabled on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasErrorEvent

This event records when there is a HA error on a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDasOkEvent

This event records when HA on a host returns to normal after an error.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDisconnectedEvent

This event records the completion of a user requested disconnect of a host. Following this event, there will be a VmDisconnectedEvent generated for each VM on the host, regardless of the VM's power state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostDVPortEvent

dvPort connected to host changed status

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event HostEnableAdminFailedEvent

This event records the failure to restore some of the administrator's permissions.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostExtraNetworksEvent

This event records the fact that a host has extra networks not used by other hosts for HA communication.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostGetShortNameFailedEvent

This event records that hostname -s failed or returned a name containing '.'.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostInAuditModeEvent

Host is running in audit mode

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event HostInventoryFullEvent

This event records if the inventory of hosts has reached the capacity of the current version of vCenter.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostInventoryUnreadableEvent

Event indicating that the virtual machine inventory file on the host is damaged or unreadable.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostIpChangedEvent

This event records a change in host IP address.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostIpInconsistentEvent

This event records that the IP address resolution returned different addresses on the host. Please check your host's network configuration.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostIpToShortNameFailedEvent

This event records that the host's IP address could not be resolved to a short name.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostIsolationIpPingFailedEvent

This event records that the isolation address could not be pinged. The default isolation address is the service console's default gateway.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostLicenseExpiredEvent

This event records an expired host license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostLocalPortCreatedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event HostMissingNetworksEvent

This event records the fact that a host is missing networks that other hosts are using for HA communication.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostMonitoringStateChangedEvent

This event records when host monitoring state has changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNoAvailableNetworksEvent

This event records the fact that a host does not have any available networks for HA communication.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNoHAEnabledPortGroupsEvent

This event records the fact that a host does not have any HA-enabled port groups.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNonCompliantEvent

This event records that host went out of compliance.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostNoRedundantManagementNetworkEvent

This event records the fact that a host does not have a redundant management network. It is recommended that host management networks be configured with redundancy.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostNotInClusterEvent

This event records that the host is not a cluster member.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostOvercommittedEvent

This event records when a host's capacity cannot satisfy resource configuration constraints.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostPrimaryAgentNotShortNameEvent

This event records that the primary agent specified is not a short name. The name of the primary agent is usually stored as a short name. You should not normally see this error. Please check the network configurations of your hosts.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostProfileAppliedEvent

This event records that a Profile application was done on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostReconnectionFailedEvent

This event records a failed attempt to re-establish a host connection.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostRemovedEvent

This event records the removal of a host from vCenter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostShortNameInconsistentEvent

This event records that host name resolution returned different names on the host. Please check your host's network configuration and your DNS configuration. There may be duplicate entries.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostShortNameToIpFailedEvent

This event records that host name resolution returned different names on the host. Please check your host's network configuration and your DNS configuration. There may be duplicate entries.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostShutdownEvent

This event records the shutdown of a host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostStatusChangedEvent

This event records when a host's overall status changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostSyncFailedEvent

This event records a failure to sync up with the vCenter agent on the host.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostUpgradeFailedEvent

This event records a failure to connect to a host due to an installation or upgrade issue.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event HostUserWorldSwapNotEnabledEvent

This event records that the userworld swap is not enabled on the host. HA needs userworld swap to be configured on embedded ESX hosts to function.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostVnicConnectedToCustomizedDVPortEvent

This event records when some host vnics were reconfigured to use DVPorts with port level configuration, which might be different from the DVportgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event HostWwnChangedEvent

This event records a change in a host's WWN (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event HostWwnConflictEvent

This event records a conflict of host WWNs (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event IncorrectHostInformationEvent

This event records if the host did not provide the information needed to acquire the correct set of licenses.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event InfoUpgradeEvent

This event is a general information event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event InsufficientFailoverResourcesEvent

This event records that the cluster resources are insufficient to satisfy the configured HA failover level.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event InvalidEditionEvent

This event records if the license edition is set to an invalid value.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event IScsiBootFailureEvent

Could not boot from iScsi

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event LicenseExpiredEvent

This event records the expiration of a license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LicenseNonComplianceEvent

This event records that the inventory is not license compliant.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event LicenseRestrictedEvent

This event records if the required licenses could not be reserved because of a restriction in the option file.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event LicenseServerAvailableEvent

This event is reported if the LicenseServer was previously unreachable and is now reachable.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LicenseServerUnavailableEvent

This event is reported if the LicenseServer becomes unreachable.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LocalDatastoreCreatedEvent

This event records when a local datastore is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event LocalTSMEnabledEvent

Local Tech Support Mode for the host has been enabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event LockerMisconfiguredEvent

Locker has not been configured properly. This event is fired when the datastore configured to back the locker does not exist or when connectivity to the datastore is lost.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event LockerReconfiguredEvent

Locker has not been configured properly. This event is fired when the datastore configured to back the locker does not exist or when connectivity to the datastore is lost.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event MigrationErrorEvent

A migration error occurred.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationHostErrorEvent

This records a migration error that includes the destination host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationHostWarningEvent

This records a migration warning that includes the destination host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationResourceErrorEvent

This records a migration error that includes both the destination host and resource pool.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationResourceWarningEvent

This records a migration warning that includes both the destination host and resource pool.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MigrationWarningEvent

This records a migration warning.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event MtuMatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event MtuMismatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event NASDatastoreCreatedEvent

This event records when a NAS datastore is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NetworkRollbackEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event NoAccessUserEvent

This event records a failed user logon due to insufficient access permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NoDatastoresConfiguredEvent

No datastores have been configured on the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event NoLicenseEvent

A NoLicenseEvent is reported if the required licenses could not be reserved. Each feature that is not fully licensed is reported.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NoMaintenanceModeDrsRecommendationForVM

This event records that DRS did not recommend a migration for a powered on virtual machine, even though its host is going into maintenance mode. DRS may not be able to recommend a migration for a virtual machine for reasons, include but not limited to:

· No other connected host is compatible with this virtual machine.
· None of the other compatible hosts have sufficient resources to satisfy the reservation requirements of this virtual machine.
· Moving to any other host would violate a DRS rule. For example, all other compatible hosts have some incompatible virtual machines running.
· DRS is disabled on this virtual machine.
· This virtual machine was still in the process of migrating into the host going into maintenance mode and was not considered by DRS.
· This virtual machine was in the process of migrating to another host when the host tried to enter maintenance mode.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event NonVIWorkloadDetectedOnDatastoreEvent

This event records that non-VI workload is detected on the datastore

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event NotEnoughResourcesToStartVmEvent

This event records when the HA does not find sufficient resources to failover a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event OutOfSyncDvsHost

The list of hosts that have the DVS configuration on the host diverged from that of the vCenter Server.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event PermissionAddedEvent

This event records the creation of a permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event PermissionRemovedEvent

This event records the removal of a permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event PermissionUpdatedEvent

This event records the update of a permission.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ProfileAssociatedEvent

This event records that a Profile was associated with a managed entitiy.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileChangedEvent

This event records that the profile has beed edited.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileCreatedEvent

This event records that a Profile was created.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileDissociatedEvent

This event records that a Profile was dissassociated from a managed entity.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileEvent

This event records a Profile specific event.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileReferenceHostChangedEvent

This event records that the reference host associated with this profile has changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event ProfileRemovedEvent

This event records that a Profile was removed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event RecoveryEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event RemoteTSMEnabledEvent

Remote Tech Support Mode for the host has been enabled

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event ResourcePoolCreatedEvent

This event records when a new resource pool is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourcePoolDestroyedEvent

This event records when a resource pool is destroyed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourcePoolMovedEvent

This event records when a resource pool is moved.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourcePoolReconfiguredEvent

This event records when a resource pool configuration is changed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ResourceViolatedEvent

This event records when a conflict with a resource pool's resource configuration is detected.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RoleAddedEvent

This event records the creation of a role.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RoleRemovedEvent

This class records the removal of a role.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RoleUpdatedEvent

This event records the creation of a role.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event RollbackEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event ScheduledTaskCompletedEvent

This event records the completion of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskCreatedEvent

This event records the creation of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskEmailCompletedEvent

This event records the sending of a notification via email for a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskEmailFailedEvent

This event records the failure of an attempt to send a notification via email for a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskEvent

This event records the completion of a scheduled task. The name of the task is indicated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskFailedEvent

This event records the failure of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskReconfiguredEvent

This event records the reconfiguration of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskRemovedEvent

This event records the removal of a scheduled task.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ScheduledTaskStartedEvent

This event records when a scheduled task started.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ServerLicenseExpiredEvent

This event records an expired vCenter server license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event ServerStartedSessionEvent

This event records the starting of the vCenter server.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event SessionTerminatedEvent

This event records the termination of a session.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TaskEvent

This event records the completion of a manually triggered task. The name of the task is indicated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TaskTimeoutEvent

This event records when a task is cleaned up because of a timeout.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event TeamingMatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event TeamingMisMatchEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event TemplateBeingUpgradedEvent

This event records the start of a template upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TemplateUpgradedEvent

This event records that the template upgrade succeeded.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TemplateUpgradeFailedEvent

This event records that the template upgrade failed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event TimedOutHostOperationEvent

This event indicates that an operation performed on the host timed out. Typically, a previous event in the sequence of events contains more information about the cause of the operation timing out.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UnlicensedVirtualMachinesEvent

This event records that we have unlicensed virtual machines on the specified host. This can be both a Config issue and an entry in the event log.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event UnlicensedVirtualMachinesFoundEvent

This event records that we discovered unlicensed virtual machines on the specified host. After this event is entered into the event log, we expect to see a corresponding UnlicensedVirtualMachinesEvent configIssue on the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event UpdatedAgentBeingRestartedEvent

This event records that the agent has been patched and will be restarted.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event UpgradeEvent

This event records that the agent has been patched and will be restarted.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UplinkPortMtuNotSupportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UplinkPortMtuSupportEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UplinkPortVlanTrunkedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UplinkPortVlanUntrunkedEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event UserAssignedToGroup

This event records that a user account membership was added to a group.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserLoginSessionEvent

This event records a user logon. Because these are so prolific, they are ignored (by default) by the Veeam VMware Collector.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserLogoutSessionEvent

This event records a user logout. Because these are so numerous, they are ignored (by default) by the Veeam VMware Collector.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserPasswordChanged

This event records that a user password changed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserUnassignedFromGroup

This event records that a user account membership was removed from a group.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event UserUpgradeEvent

This event is a general user event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VcAgentUninstalledEvent

This event records when the vCenter agent on a host is uninstalled.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VcAgentUninstallFailedEvent

This event records when the vCenter agent on a host failed to uninstall.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VcAgentUpgradedEvent

This event records when the vCenter agent on a host upgraded.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VcAgentUpgradeFailedEvent

This event records when the vCenter agent on a host failed to upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event vim.event.LicenseDowngradedEvent

License downgrade

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VimAccountPasswordChangedEvent

Password for the Vim account user on the host has been changed. This is an account created by vCenter and used to manage the host.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmAcquiredMksTicketEvent

This event records a user successfully acquiring an MKS ticket (i.e., a mouse-keyboard-screen connection ticket).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmAcquiredTicketEvent

This event records a user successfully acquiring a ticket

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmAutoRenameEvent

This event records that a virtual machine was automatically renamed because of a name conflict.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingClonedEvent

This event records a virtual machine being cloned.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingClonedNoFolderEvent

This event records a virtual machine being cloned

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmBeingCreatedEvent

This event records a virtual machine being created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingDeployedEvent

This event records a virtual machine being deployed from a template.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingHotMigratedEvent

This event records that a virtual machine is being hot-migrated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingMigratedEvent

This event records that a virtual machine is being migrated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmBeingRelocatedEvent

This event records that a virtual machine is being relocated.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmClonedEvent

This event records the completion of a virtual machine cloning operation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmCloneFailedEvent

This event records a failure to clone a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmConfigMissingEvent

This event records if the configuration file can not be found.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmConnectedEvent

This event is generated by the VC for each VM on a host whenever the host is reconnected to the VC. One event per VM will be generated, regardless of the power state of the VM.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmCreatedEvent

This event records that a virtual machine was successfully created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDasBeingResetEvent

This event records when a virtual machine is reset by HA VM Health Monitoring on hosts that do not support the create screenshot api or if the createscreenshot api fails.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmDasBeingResetWithScreenshotEvent

This event records when a virtual machine is reset by HA VM Health Monitoring on hosts that support the create screenshot api.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmDasResetFailedEvent

This event records when HA VM Health Monitoring fails to reset a virtual machine after failure.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmDasUpdateErrorEvent

The event records that an error occured when updating the HA agents with the current state of the virtual machine. If this occurs during a powerOn operation, the virtual machine will not be failed over in the event of a host failure. If it occurs during a powerOff, the virtual machine will be automatically powered on if the host it was last running on crashes.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDasUpdateOkEvent

This event records that HA agents have been updated with the current state of the virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDateRolledBackEvent

This event records when the vCenter server date rolled back.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDeployedEvent

This event records the completion of a virtual machine deployment operation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDeployFailedEvent

This event records a failure to deploy from a template.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDisconnectedEvent

This event is generated by the VC for each VM on a host whenever the host becomes disconnected from the VC. One event per VM will be generated, regardless of the power state of the VM.

"Disconnection" of the host includes both planned disconnections (indicated by HostDisconnectedEvent) and unplanned disconnections (indicated by HostConnectionLostEvent).

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDiscoveredEvent

This event records a virtual machine discovery.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDiskFailedEvent

This event records a failure to create a virtual disk in a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmDVPortEvent

dvPort connected to VM changed status

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmEmigratingEvent

This event records a virtual machine migration.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmEndRecordingEvent

This event indicates the end of a recording session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmEndReplayingEvent

This event indicates the end of a replay session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmEvent

This is a catch-all event for various VM events (the type of event is listed in the event). See VMware's documentation for the list of possible events.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedMigrateEvent

This event records a failure to migrate a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedRelayoutEvent

This event records a specific failure to re-layout a virtual machine, such as a failure to access the disk. "Layout" refers to the reformatting of the data on the disk to match VMware's latest VMFS3 structure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedRelayoutOnVmfs2DatastoreEvent

This event records a failure to re-layout a virtual machine when the virtual machine still has disks on a VMFS2 volume. "Layout" refers to the reformatting of the data on the disk to match VMware's latest VMFS3 structure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedStartingSecondaryEvent

This event records vmotion failure when starting a secondary VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFailedToPowerOffEvent

This event records a failure to power off a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToPowerOnEvent

This event records a failure to power on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToRebootGuestEvent

This event records a failure to reboot the guest on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToResetEvent

This event records a failure to reset a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToShutdownGuestEvent

This event records a failure to shut down the guest on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToStandbyGuestEvent

This event records a failure to set the guest on a virtual machine toa standby state.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedToSuspendEvent

This event records a failure to suspend a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFailedUpdatingSecondaryConfig

This event records after a failover the new new primary failed to update the config of the secondary vm.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFailoverFailed

This event records when a virtual machine failover was unsuccessful.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmFaultToleranceStateChangedEvent

This event records a fault tolerance state change. A default alarm will be triggered upon this event, which would change the vm state: the vm state is red if the newState is needSecondary; the vm state is yellow if the newState is disabled; the vm state is green if the newState is notConfigured, starting, enabled or running.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFaultToleranceTurnedOffEvent

This event records that all secondary virtual machines have been removed and fault tolerance protection turned off for this virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmFaultToleranceVmTerminatedEvent

This event records a secondary or primary VM is terminated. The reason could be : divergence, lost connection to secondary, partial hardware failure of secondary, or by user.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VMFSDatastoreCreatedEvent

This event records when a VMFS datastore is created.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VMFSDatastoreExpandedEvent

This event records when a datastore is expanded.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VMFSDatastoreExtendedEvent

This event records when a datastore is extended.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmGuestRebootEvent

This is a virtual machine guest reboot request event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmGuestShutdownEvent

This is a virtual machine guest shutdown request event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmGuestStandbyEvent

This is a virtual machine guest standby request event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmHealthMonitoringStateChangedEvent

This event records when host monitoring state has changed.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmInstanceUuidAssignedEvent

This event records the assignment of a new instance UUID to a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmInstanceUuidChangedEvent

This event records a change in a virtual machine's instance UUID.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmInstanceUuidConflictEvent

This event records a conflict of virtual machine instance UUIDs.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMacAssignedEvent

This event records the assignment of a new MAC address to a virtual network adapter.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMacChangedEvent

This event records a change in a virtual machine's MAC address.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMacConflictEvent

This event records a MAC address conflict for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMaxFTRestartCountReached

This event is fired when FT VM reached the max restart count.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMaxRestartCountReached

This event is fired when the VM reached the max restart count.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMessageErrorEvent

This event records when an error message (consisting of a collection of "observations") is thrown by the virtual machine. This is a generic event for such messages.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMessageEvent

This event records when a message is thrown by the virtual machine. This is a generic event for such messages.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmMessageWarningEvent

This event records when a warning message (consisting of a collection of "observations") is thrown by the virtual machine. This is a generic event for such messages.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmMigratedEvent

This event records a virtual machine migration.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmNoCompatibleHostForSecondaryEvent

This event records that no compatible host was found to place a secondary VM. A default alarm will be triggered upon this event, which by default would trigger a SNMP trap.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmNoNetworkAccessEvent

This event records a migration failure when the destination host is not on the same network as the source host.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmOrphanedEvent

This event records a virtual machine for which no host is responsible.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VMotionLicenseExpiredEvent

This event records an expired VMotion license.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPoweredOffEvent

This event records when a virtual machine finished powering off.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPoweredOnEvent

This event records when a virtual machine finished powering on.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPoweringOnWithCustomizedDVPortEvent

This event records when a virtual machine was powering on using DVPorts with port level configuration, which might be different from the DVportgroup.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmPowerOffOnIsolationEvent

This event records when a virtual machine has been powered off on an isolated host in a HA cluster.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmPrimaryFailoverEvent

This event records an fault tolerance failover. The reason could be : lost connection to primary, partial hardware failure of primary or by user.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmReconfiguredEvent

This event records a reconfiguration of the virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRegisteredEvent

This event records that a virtual machine was successfully registered.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRelayoutSuccessfulEvent

This event records that a virtual machine was successfully converted to the new virtual machine format on a VMFS3 volume.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRelayoutUpToDateEvent

This event records that a virtual machine is already in the correct format. No re-layout is necessary. "Layout" refers to the reformatting of the data on the disk to match VMware's latest VMFS3 structure.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmReloadFromPathEvent

This event records that a virtual machine was successfully reloaded from a new configuration path

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmReloadFromPathFailedEvent

This event records that a virtual machine reload from a new configuration path failed

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event VmRelocatedEvent

This event records the completion of a virtual machine relocation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRelocateFailedEvent

This event records a failure to relocate a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRemoteConsoleConnectedEvent

This event records that a remote console was connected to the VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmRemoteConsoleDisconnectedEvent

This event records that a remote console was disconnected from the VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmRemovedEvent

This event records a virtual machine removed from vCenter management.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRenamedEvent

This event records the renaming of a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRequirementsExceedCurrentEVCModeEvent

Since VI API 5.1 . For more information, please refer to the VMware api reference

• Event VmResettingEvent

This event records a virtual machine resetting.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmResourcePoolMovedEvent

This event records when a virtual machine is moved from one resource pool to another.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmResourceReallocatedEvent

This event records a change in resource allocation of a virtual machine.

The name of the virtual machine is in the event. This event is generated typically in DRS configurations when VC detects that the available resources (such as CPU) are changing.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmRestartedOnAlternateHostEvent

This event records that the virtual machine was restarted on a host, since its original host had failed.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmResumingEvent

This event records a virtual machine resuming.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryAddedEvent

This event records a secondary VM is added.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryDisabledBySystemEvent

This event records that a fault tolerance secondary VM has been disabled by vCenter because the VM could not be powered on.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryDisabledEvent

This event records a secondary VM is disabled.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryEnabledEvent

This event records a secondary VM is enabled.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmSecondaryStartedEvent

This event records a secondary VM is started successfully.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmShutdownOnIsolationEvent

This event records when a virtual machine has been shut down on an isolated host in a HA cluster.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStartingEvent

This event records a virtual machine powering on. It typically will be followed by a VmPoweredOnEvent.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmStartingSecondaryEvent

This event records a vmotion to start a secondary VM.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStartRecordingEvent

This event indicates the start of a recording session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStartReplayingEvent

This event indicates the start of a replay session on a virtual machine.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmStaticMacConflictEvent

This event records a static MAC address conflict for a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmStoppingEvent

This event records a virtual machine stopping.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmSuspendedEvent

This event records when a virtual machine finished suspending.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmSuspendingEvent

This event records a virtual machine suspending.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmTimedoutStartingSecondaryEvent

This event records timeout when starting a secondary VM. A default alarm will be triggered upon this event, which by default would trigger a SNMP trap.

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event VmUnsupportedStartingEvent

This event records when an unsupported guest is powering on.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUpgradeCompleteEvent

This event records the successful completion of an upgrade operation.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUpgradeFailedEvent

This event records a failure to upgrade virtual hardware.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUpgradingEvent

This event records the process of upgrading the virtual hardware on a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUuidAssignedEvent

This event records the assignment of a new BIOS UUID to a virtual machine.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUuidChangedEvent

This event records a change in a virtual machine's BIOS UUID. Veeam has observed that during migrations this event may be generated even though the UUID is not changing.

A sample event is included below (note that on this version of ESX the name of the VM is missing after the word "for", and the UUID is actually not changing).

Changed BIOS UUID from 500e3054-23fd-6ff6-58a7-037500940891 to 500e3054-23fd-6ff6-58a7-037500940891 for on esx04.seattle.veeam.local in SEATTLE VmUuidChangedEvent

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmUuidConflictEvent

This event records a conflict of virtual machine BIOS UUIDs. That is, a virtual machine has been detected with a duplicate UUID (Universally Unique Identifier).

When a VM is cloned, its UUID is also clone and will remain with the same UUID until 2 VMs with the same UUID are powered on. Only when the VM is running is the uniqueness of UUIDs assured. When the hypervisor detects a VM powering up has a duplicate UUID it will change it and issue this event.

Since VI API 2.0 . For more information, please refer to the VMware api reference

• Event VmVnicPoolReservationViolationClearEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event VmVnicPoolReservationViolationRaiseEvent

Since VI API 5.5 . For more information, please refer to the VMware api reference

• Event VmWwnAssignedEvent

This event records the assignment of a new WWN (World Wide Name) to a virtual machine.

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmWwnChangedEvent

This event records a change in a virtual machine's WWN (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event VmWwnConflictEvent

This event records a conflict of virtual machine WWNs (World Wide Name).

Since VI API 2.5 . For more information, please refer to the VMware api reference

• Event vprob.net.connectivity.lost

Lost Network Connectivity

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.e1000.tso6.notsupported

No IPv6 TSO support

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.migrate.bindtovmk

Invalid vmknic specified in /Migrate/Vmknic

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.proxyswitch.port.unavailable

VNic connect to switch failed

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.redundancy.degraded

Network Redundancy Degraded

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.net.redundancy.lost

Lost Network Redundancy

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.scsi.device.thinprov.atquota

Space utilization on thin-provisioned device exceeded configured threshold

Since VI API 4.1 . For more information, please refer to the VMware api reference

• Event vprob.storage.connectivity.lost

Lost Storage Connectivity

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.storage.redundancy.degraded

Degraded Storage Path Redundancy

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.storage.redundancy.lost

Lost Storage Path Redundancy

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.error.volume.is.locked

Volume is locked

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.extent.offline

Device is offline

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.extent.online

Device is online

Since VI API 5.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.heartbeat.recovered

VMFS Volume Connectivity Restored

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.heartbeat.timedout

VMFS Volume Connectivity Degraded

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.heartbeat.unrecoverable

VMFS Volume Connectivity Lost

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.journal.createfailed

No Space To Create VMFS Journal

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.lock.corruptondisk

VMFS Lock Corruption Detected

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.nfs.server.disconnect

Lost connection to NFS server

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.nfs.server.restored

Restored connection to NFS server

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.resource.corruptondisk

VMFS Resource Corruption Detected

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event vprob.vmfs.volume.locked

VMFS Locked By Remote Host

Since VI API 4.0 . For more information, please refer to the VMware api reference

• Event WarningUpgradeEvent

This event is a general warning event from upgrade.

Since VI API 2.0 . For more information, please refer to the VMware api reference